Monday, January 16, 2012

Packaging for Mac OS X

I have built a package for Mac OS X. This should make things a bit easier to test. This one requires at least Snow Leopard, as Apple made some changes to their Cocoa library that prevents it from linking correctly under Leopard. I am working on creating a Leopard-compatible build for those with PowerPC Macs.
Windows packaging is a bit more of a pain; I have made a executable but I am witholding it for now while I fix some rather fatal bugs on that platform.
I will create a .deb package for Linux tonight; I might make an .rpm, but I haven't made rpms before so I don't know how hard that will be.

You can download the app at:
https://github.com/downloads/skykooler/Lightningbeam/Lightningbeam.zip

1 comment: